WordPress导入数据库出现”Unknown collation: ‘utf8_unicode_ci”错误的解决办法

  • Post category:博客
  • Post comments:1评论

从WordPress4.2版本开始,如果我们在MYSQL5.1版本数据中导出的数据编码是带有utf8格式的,如果我们搬迁网站复原数据的时候,MYSQL5.5等高版本数据库导入到MYSQL5.1低版本的时候会出现”Unknown collation: ‘utf8_unicode_ci”错误问题,以前是没有这个问题的,从WP4.2开始才有的。

要解决这个问题,如果我们使用的VPS/服务器,可以类似老左昨天的”Linux CentOS6环境下MySQL5.1升级至MySQL5.5版本过程”方法进行升级MYSQL数据库版本,这样就不会存在不兼容问题,但是如果我们使用的虚拟主机或者升级MYSQL存在一定的技术活,要是处理错误还真的比较麻烦。我们这里可以在导出数据库的时候选择兼容版本。

解决方法:

一、修改数据库文件

在导入数据库之前,用代码编辑器打开需要导入的数据库文件。
查找:utf8_unicode_ci 替换为: utf8_general_ci

查找:utf8 替换为: utf8
替换的时候一定要注意顺序,如果先替换utf8,再替换utf8_unicode_ci就会找不到utf8_unicode_ci而造成替换失败。

二:修改wp-config.php文件

define(‘DB_CHARSET’, ‘utf8’);
改为:

define(‘DB_CHARSET’, ‘utf8’);

搞定!

这篇文章有一个评论

  1. 一位WordPress评论者

    嗨,这是一条评论。
    要开始审核、编辑及删除评论,请访问仪表盘的“评论”页面。
    评论者头像来自Gravatar

发表评论